the commands in this appendix are organized in the...

24
The commands in this appendix are organized in the following sections: General Commands Comparison of Configuration File Commands General Configuration Commands General Interface Configuration Commands General IP Commands IP Configuration Commands WAN Configuration Commands CLNS Configuration Commands

Upload: others

Post on 26-May-2020

4 views

Category:

Documents


0 download

TRANSCRIPT

Page 1: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

The commands in this appendix are organized in the following sections:

General Commands

Comparison of Configuration File Commands

General Configuration Commands

General Interface Configuration Commands

General IP Commands

IP Configuration Commands

WAN Configuration Commands

CLNS Configuration Commands

Page 2: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

A P P E N D I X

F

Summary of BSCI Router Commands

This appendix contains a listing of some of the Cisco router IOS commands you might find in this book, organized in various categories.

General Commands

Table F-1 contains some Cisco router EXEC IOS commands.

NOTE

This appendix lists only the command; parameters are not included. For details about the parameters and how the command works, see the relevant chapters in this book and refer to the Command Reference Manuals

at http://www.cisco.com/univercd/cc/td/doc/.

Table F-1

General Commands

Command Meaning

clear access-list counters

Clears packet counters in extended access lists.

clear counters tunnel

Clears the counters displayed in the

show interface tunnel

command.

clear logging

Clears the logging buffer.

configure terminal

Enters configuration mode.

copy running-config startup-config

Copies configuration from random-access memory (RAM) to nonvolatile random-access memory (NVRAM) (overwrites).

debug

Starts the console display of the events on the router.

debug eigrp neighbors

Starts the console display of the Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor interaction.

debug eigrp packets

Starts the console display of EIGRP packets, both sent and received.

erase startup-config

Erases the configuration in NVRAM.

continues

Page 3: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

4

Appendix F: Summary of BSCI Router Commands

Command Meaning

ping

Sends an echo and expects an echo reply. Extended

ping

allows specification of the source address and allows

ping

for protocols other than Internet Protocol (IP).

reload

Reloads the operating system.

setup

Enters a prompted dialog to establish an initial configuration.

show access-lists

Displays the contents of all access lists configured.

show cdp interface

Displays information about interfaces configured to run Cisco Discovery Protocol (CDP).

show cdp neighbors

Displays a summary of CDP information received from neighbors.

show cdp neighbors detail

Displays detailed CDP information received from neighbors.

show controller

Displays the Layer 1 information about an interface (including cable type and data circuit-terminating equipment / data terminal equipment [DCE/DTE] status for serial interfaces).

show frame-relay map

Displays the mapping between network layer addresses and data-link connection identifiers (DLCIs), both static and dynamic mappings.

show interfaces

Displays information about interfaces or an interface, including the state of the interface and queuing information.

show line

Displays information about line (

console

, auxiliary [

aux

], or virtual terminal [

vty

]) configuration.

show logging

Displays the logging buffer, including logged output of

debug

commands.

show route-map

Displays configured route maps; includes number of matches.

show running-config

Displays the active configuration (in RAM). Use

| begin

to specify where in the configuration you want to begin the display (for example,

show running-config | begin interface

starts the display at the first

interface

command).

show startup-config

Displays the backup configuration (in NVRAM).

show version

Displays configuration of system hardware, software version, and configuration register value.

telnet

Connects to a host that supports Telnet.

traceroute

Traces the route that packets are taking through the network; extended

traceroute

allows specification of the source address.

Table F-1

General Commands (Continued)

Page 4: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

Comparison of Configuration File Commands

5

Comparison of Configuration File Commands

With Cisco IOS Software Release 12.0, commands used to copy and transfer configuration and system files have changed to conform to Cisco IOS File System (IFS) specifications. The old commands continue to perform their normal functions in the current release, but support for these commands will cease in a future release. Table F-2 contains the old and new commands used for configuration file movement and management.

Table F-2

Comparison of Configuration File Commands

Old Commands New Commands

configure network

(pre-IOS Release 10.3)

copy rcp running-config

copy tftp running-config

copy ftp: system:running-config

copy rcp: system:running-config

copy tftp: system:running-config

configure overwrite-network

(pre-IOS Release 10.3)

copy rcp startup-config

copy tftp startup-config

copy ftp: nvram:startup-config

copy rcp: nvram:startup-config

copy tftp: nvram:startup-config

show configuration

(pre-IOS Release 10.3)

show startup-config

more nvram:startup-config

write erase

(pre-IOS Release 10.3)

erase startup-config

erase nvram:

write memory

(pre-IOS Release 10.3)

copy running-config startup-config

copy system:running-config nvram: startup-config

write network

(pre-IOS Release 10.3)

copy running-config rcp

copy running-config tftp

copy system:running-config ftp:

copy system:running-config rcp:

copy system:running-config tftp:

write terminal

(pre-IOS Release 10.3)

show running-config

more system:running-config

Page 5: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

6

Appendix F: Summary of BSCI Router Commands

General Configuration Commands

Table F-3 contains some Cisco IOS commands used for general router configuration.

Table F-3

General Configuration Commands

Command Meaning

cdp timer

Specifies the interval at which CDP updates are sent.

config-register

Changes the value of the configuration register.

default interface

Erases the configuration on the specified interface.

enable password

Specifies the enable password for the router.

enable secret

Specifies the enable secret password for the router.

exec-timeout 0 0

Sets the timeout for a line EXEC session to zero, preventing the session from timing out and disconnecting.

hostname

Specifies the router’s name.

interface

Enters interface configuration mode (

ethernet

,

serial

,

loopback

, and so on). Also used to enter subinterface configuration mode. For virtual interfaces (

loopback

,

tunnel

,

dialer

, and so on), the first time that this command is used for a specific virtual interface, it creates that virtual interface.

ip domain lookup

Enables Domain Name Service (DNS) lookup; use

no ip domain lookup

to disable DNS lookup.

line

Enters line configuration mode (

console

,

aux

,

vty

).

logging synchronous

When used on a line (

console

,

aux

,

vty

), causes input to be redisplayed on a single display line, at the end of each console message that interrupts the input.

login

Enables password checking on a line.

match

Defines conditions to be checked within a route map.

password

Specifies the password for a line.

route-map

Defines a route map and enters configuration mode for the route map.

service password-encryption

Causes all passwords to be stored and displayed in encrypted form.

set

Defines actions to be followed if there is a match within a route map.

Page 6: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

General IP Commands

7

General Interface Configuration Commands

Table F-4 contains some Cisco IOS commands for interface configuration.

General IP Commands

Table F-5 contains some Cisco IOS EXEC commands related to IP.

Table F-4

General Interface Configuration Commands

Command Meaning

bandwidth

Sets bandwidth of interface (used by some routing protocols, including Open Shortest Path First [OSPF], EIGRP; also used for load calculations)

clock rate

Sets clock rate in bits per second (used if interface is DCE)

interface

Enters interface configuration mode (or subinterface mode, if already in interface mode)

interface serial multipoint | point-to-point

Enters subinterface configuration mode for a serial interface, and defines whether it is a multipoint or point-to-point subinterface

shutdown

Administratively shuts down an interface (use

no shutdown

to bring up the interface)

Table F-5

General IP Commands

Command Meaning

clear ip bgp

Causes a hard reset of Border Gateway Protocol (BGP) neighbors. Use the

*

option to clear all sessions.

clear ip bgp soft

Causes the BGP router to do a soft reconfiguration of both inbound and outbound updates.

clear ip bgp soft in

Causes the BGP router to use the stored unfiltered table to generate new inbound updates. If route refresh is supported, a dynamic soft reset of inbound BGP updates is done, without requiring any stored information.

clear ip bgp soft out

Causes a soft reset of BGP outbound updates.

clear ip bgp peer-group

Resets the BGP connections for all members of a BGP peer group.

clear ip dhcp binding

Deletes an automatic address binding from the Dynamic Host Configuration Protocol (DHCP) database.

clear ip dhcp conflict Clears an address conflict from the DHCP database.

continues

Page 7: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

8 Appendix F: Summary of BSCI Router Commands

Command Meaning

clear ip dhcp server statistics Resets all DHCP server counters to 0.

clear ip ospf process Restarts the OSPF routing process, including selecting the OSPF router ID.

clear ip prefix-list Resets the hit count shown on IP prefix list entries.

clear ip route Clears the IP routing table. Use the * option to delete all routes.

clear ip route dhcp Removes routes from the routing table added by the Cisco IOS DHCP server and relay agent.

clear ipv6 ospf Triggers shortest path first (SPF) recalculation and repopulation of the Routing Information Base (RIB).

clear isis Forces Intermediate System-to-Intermediate System (IS-IS) to refresh its link-state database and recalculate all routes.

debug dhcp detail Displays the DHCP packets that were sent and received.

debug eigrp neighbors Displays neighbors discovered by EIGRP and the contents of the hello packets.

debug eigrp packets Displays the types of EIGRP packets sent and received. A maximum of 11 packet types can be selected for individual or group display. Output includes indication of when EIGRP authentication is being used.

debug ip bgp Starts the console display of BGP-related events on the router, according to the option specified (dampening, events, keepalives, updates).

debug ip bgp ipv4 unicast Starts the console display of IP Version 4 (IPv4) BGP unicast events, including the states that two BGP routers go through to establish a session.

debug ip bgp updates Starts the console display of BGP updates.

debug ip dhcp server Displays the server side of the DHCP interaction.

debug ip eigrp Starts the console display of the IP EIGRP packets that are sent and received on an interface.

debug ip eigrp summary Displays a summarized version of IP EIGRP activity. It also displays filtering and redistribution numbers, and neighbors and distance information.

debug ip ospf adj Starts the console display of OSPF adjacency-related events on the router.

Table F-5 General IP Commands (Continued)

Page 8: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

General IP Commands 9

Command Meaning

debug ip ospf events Starts the console display of OSPF-related events, such as adjacencies, flooding information, designated router selection, and SPF calculation on the router.

debug ip ospf lsa-generation Starts the console display of OSFP link-state advertisement (LSA) generation-related events on the router.

debug ip ospf packet Starts the console display of each OSPF packet received.

debug ip ospf spf Starts the console display of SPF calculation-related events on the router.

debug ip packet Starts the console display of IP packet events.

debug ip policy Starts the console display of IP policy routing events.

debug ip rip Starts the console display of IP Routing Information Protocol (RIP)-related events on the router.

debug ip routing Starts the console display of IP routing-related events on the router.

debug isis adj-packets Displays IS-IS adjacency-related packets.

debug isis update-packets Displays IS-IS update-related packets.

mrinfo Displays information about multicast routers that are peering with the local router (if no address is specified) or with the specified router.

release dhcp For interfaces configured to be DHCP clients, releases the DCHP lease for the interface and deconfigures the IP address for the interface.

renew dhcp For interfaces configured to be DHCP clients, renews the DHCP lease.

show clns Displays general information about the Connectionless Network Service (CLNS) network.

show clns interface Displays CLNS-specific information about interfaces running IS-IS.

show clns is-neighbors Displays IS-IS related information for IS-IS router adjacencies.

show clns neighbors Displays Intermediate System (IS) and End System (ES) neighbors.

continues

Table F-5 General IP Commands (Continued)

Page 9: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

10 Appendix F: Summary of BSCI Router Commands

Command Meaning

show clns protocol Displays information for the specific IS-IS processes in the router.

show clns route Displays the IS-IS Level 2 routing table.

show ip access-list Displays the IP access lists configured.

show ip bgp Displays the BGP table; specify a network number to get more specific information about a particular network.

show ip bgp neighbors Displays information about the Transmission Control Protocol (TCP) and BGP connections to neighbors.

show ip bgp rib-failure Displays BGP routes that were not installed in the RIB, and the reason they were not installed.

show ip bgp summary Displays the status of all BGP connections.

show ip dhcp binding Displays a list of all bindings created on a specific DHCP server.

show ip dhcp conflict Displays a list of all address conflicts recorded by a specific DHCP server.

show ip dhcp database Displays recent activity in the DHCP database.

show ip dhcp import Displays the option parameters that were imported into the DHCP server database.

show ip dhcp-relay information trusted-sources

Displays all interfaces configured to be a trusted source for the DHCP relay information option.

show ip dhcp server statistics Displays server statistics and counts of the number of messages sent and received.

show ip eigrp interfaces Displays information about interfaces configured for IP EIGRP.

show ip eigrp neighbors Displays the neighbors discovered by IP EIGRP.

show ip eigrp topology Displays the IP EIGRP topology table; use the all-links keyword to display all of the topology table, including those routes that are not feasible successors.

show ip eigrp traffic Displays the number of IP EIGRP packets sent and received.

show ip igmp group Displays a list of multicast groups known to the router.

show ip igmp interface Displays Internet Group Management Protocol (IGMP)-related information about an interface, including which version of IGMP is currently active on an interface.

Table F-5 General IP Commands (Continued)

Page 10: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

General IP Commands 11

Command Meaning

show ip interface Displays IP-specific information about an interface, including whether access lists are applied.

show ip mroute Displays the IP multicast routing table.

show ip ospf Displays OSPF-specific parameters on the router, including the router ID, OSPF timers, the number of times the SPF algorithm has been executed, and LSA information.

show ip ospf border-routers Displays the internal OSPF routing table entries to Area Border Routers (ABRs) and Autonomous System Boundary Routers (ASBRs).

show ip ospf database Displays the contents of the OSPF topological database maintained by the router. This command also shows the router ID and OSPF process ID. Use additional keywords to view detailed information in each part of the database.

show ip ospf database nssa-external

Display specific details of each LSA type 7 update in database.

show ip ospf interface Displays details of the OSPF protocol on the interfaces, including the area, state, timers, neighbors, router ID, and network type.

show ip ospf neighbor Displays a list of OSPF neighbors; use the detail keyword to display more details of each neighbor (including priority and state).

show ip ospf virtual-links Displays the OSPF virtual links.

show ip pim interface Displays information about interfaces configured for Protocol Independent Multicast (PIM).

show ip pim neighbor Displays the discovered PIM neighbors.

show ip pim rp Displays rendezvous point (RP) information about active multicast groups.

show ip policy Displays route maps configured on the routers interfaces for policy routing.

show ip prefix-list Displays information on all prefix lists; use the detail keyword to include the description and hit count. Other parameters can be used to display other details or specific parts of the prefix lists.

continues

Table F-5 General IP Commands (Continued)

Page 11: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

12 Appendix F: Summary of BSCI Router Commands

Command Meaning

show ip protocols Displays the IP routing protocols that are running.

show ip route Displays the IP routing table; use other keywords to display specific parts of the routing table.

show ip route dhcp Displays the routes added to the routing table by the Cisco IOS DHCP server and relay agent.

show ip route eigrp Displays the current EIGRP entries in the IP routing table.

show ip route isis Displays the current IS-IS entries in the IP routing table.

show ip route ospf Displays the current OSPF entries in the IP routing table.

show ip rpf Displays Reverse Path Forwarding (RPF) information for the RP or source specified.

show ipv6 ospf Displays general information about OSPF for IP Version 6 (IPv6) processes

show ipv6 ospf database Displays OSPF for IPv6 database.

show ipv6 ospf database database-summary

Displays a summary of the OSPF for IPv6 database.

show ipv6 ospf database link Displays OSPF for IPv6 type 8 LSAs.

show ipv6 ospf database prefix Displays OSPF for IPv6 type 9 LSAs.

show ipv6 ospf interface Displays OSPF for IPv6-related interface information. Use the brief keyword to specify that a brief amount of information be displayed.

show ipv6 ospf neighbor Displays information about IPv6 OSPF neighbors. Use the detail keyword to display detailed information.

show ipv6 route Displays the IPv6 routing table.

show isis database Displays the contents of the IS-IS link-state database.

show isis spf-log Displays how often and why the router has run a full SPF calculation.

show isis topology Displays the IS-IS Level 1 and Level 2 topology tables, which show the least-cost IS-IS path to the intermediate systems.

show isis route Displays the IS-IS Level 1 routing table.

Table F-5 General IP Commands (Continued)

Page 12: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 13

IP Configuration Commands

Table F-6 contains some Cisco IOS configuration commands related to IP configuration.

Table F-6 IP Configuration Commands

Command Meaning

accept-lifetime For EIGRP message digest 5 (MD5) authentication, this command specifies the time period during which this key will be accepted for use on received packets.

access-class Activates an access list on a line (console, aux, vty) to restrict incoming and outgoing connections.

access-list Defines an access list: IP standard = numbers 1 to 99 or 1300 to 1999; IP extended = numbers 100 to 199 or 2000 to 2699.

aggregate-address Creates an aggregate, or summary, entry in the BGP table.

area authentication Enables authentication for an OSPF area.

area default-cost Defines the cost of the default route sent into an OSPF stub area; the default is 1.

area nssa Defines the OSPF area as a not-so-stubby area (NSSA).

area range Defines route summarization of intra-area routes on an OSPF ABR.

area stub Defines the OSPF area as a stub area; use the no-summary keyword on the ABR to define a totally stubby area.

area virtual-link Defines an OSPF virtual link across an area to another OSPF router.

auto-cost reference-bandwidth Defines the numerator of the OSPF cost formula (numerator/bandwidth), in megabits per second. The default is 100.

auto-summary Enables automatic route summarization.

For BGP, determines how redistributed routes are handled.

Use no auto-summary to turn off automatic summarization for RIP Version 2 (RIPv2) and EIGRP.

bgp always-compare-med Forces the comparison of the BGP multi-exit-discriminator (MED) attribute to be done, even if the neighboring autonomous system is not the same for all the routes considered.

continues

Page 13: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

14 Appendix F: Summary of BSCI Router Commands

Command Meaning

bgp bestpath missing-as-worst Forces BGP routes without the MED attribute to have a MED value of infinity, making the route the least preferred.

bgp cluster-id Configures the cluster ID; used if a BGP cluster has more than one route reflector (RR).

bgp default local-preference Defines the default BGP local-preference attribute value for all BGP routes.

bootfile For DHCP, specifies the name of the default boot image for a DHCP client.

client-identifier For DHCP, specifies the unique identifier for a Microsoft DHCP client, for which a manual binding is to be created.

client-name For DHCP, specifies the name of the client for which a manual binding is to be created.

default-information originate Generates a default external route into an OSPF routing domain. The optional keyword always advertises the default route regardless of whether the software has a default route in the routing table.

default-metric Defines the seed metric that this routing protocol uses before redistributing a route.

default-router For DHCP, specifies the IP address of the default router for a DHCP client.

distance Defines the administrative distance that will be used for this routing protocol (for all routing protocols except BGP and EIGRP).

distance bgp Defines the administrative distance that will be used for BGP.

distance eigrp Defines the administrative distance that will be used for EIGRP.

distance ospf Defines the administrative distance that will be used for OSPF, based on route type.

distribute-list Activates an access list to be used to filter outbound or inbound routing updates for a routing protocol.

dns-server For DHCP, specifies the IP address of a DNS server that is available to a DHCP client.

domain-name For DHCP, specifies the domain name for the client.

Table F-6 IP Configuration Commands (Continued)

Page 14: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 15

Command Meaning

eigrp log-neighbor-changes Enables the logging of changes in EIGRP neighbor adjacencies.

eigrp stub Configures a router as an EIGRP stub.

hardware-address For DHCP, specifies a hardware address for a client for which a manual binding is to be created.

host For DHCP, specifies the IP address and subnet mask of the client for which a manual binding is to be created.

import all For DHCP, imports DHCP option parameters into the DHCP server database. Used for remote DHCP pools.

ip access-group Activates an access list on an interface.

ip address Assigns an IP address and subnet mask to an interface. Use the secondary option to assign a secondary address and mask to the interface.

ip address dhcp Configures a Cisco IOS device to be a DHCP client and obtain an interface address dynamically from a DHCP server.

ip authentication key-chain eigrp

Specifies the EIGRP authentication key chain to be used on an interface.

ip authentication mode eigrp md5

Specifies that the interface will use MD5 authentication for EIGRP.

ip bandwidth-percent eigrp Defines the maximum percentage of bandwidth that EIGRP packets will be capable of utilizing on an interface.

ip classless Specifies that if a packet is received with a destination address within an unknown subnet of a directly attached network, the router will match it to the default route and forward it to the next hop specified by the default route.

ip community-list Creates a community list for BGP and controls access to the list.

ip dhcp bootp ignore Configures the DHCP server to selectively ignore and not reply to received BOOTP requests.

ip dhcp client Configures options on interfaces that are to be DHCP clients; must be configured before entering the ip address dhcp command on the interface.

ip dhcp conflict logging Enables DHCP conflict logging. Disable with the no form of the command if a DHCP database agent is not configured.

continues

Table F-6 IP Configuration Commands (Continued)

Page 15: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

16 Appendix F: Summary of BSCI Router Commands

Command Meaning

ip dhcp database Specifies the DHCP database agent and the interval between database updates and database transfers.

ip dhcp excluded-address Specifies the IP addresses that the DHCP server should not assign to DHCP clients.

ip dhcp information check For DHCP relay agent, configures DHCP to check that the relay agent information option in forwarded BOOTREPLY messages is valid. Enabled by default.

ip dhcp information option For DHCP relay agent, enables the system to insert the DHCP relay agent information option (82) in forwarded BOOTREQUEST messages to a DHCP server. Disabled by default.

ip dhcp information policy For DHCP relay agent, configures the reforwarding policy for the relay agent (what the relay agent should do if a message already contains relay information).

ip dhcp ping packets Specifies the number of ping packets the DHCP server sends to a pool address before assigning the address to a requesting client; the default is 2.

ip dhcp ping timeout Specifies the amount of time the DHCP server waits for a ping reply from an address pool. The default is 2 seconds (2000 milliseconds).

ip dhcp pool Creates a name for the DCHP server address pool and enters DHCP pool configuration mode.

ip dhcp relay information trust-all

For DHCP relay agent, configures all interfaces on a router as trusted sources of the DHCP relay information option.

ip dhcp relay information trusted

For DHCP relay agent, configures an interface on a router as a trusted source of the DHCP relay information option.

ip dhcp smart-relay For DHCP, used if you have secondary addresses on the interface where the User Datagram Protocol (UDP) broadcasts that you want to forward to the DHCP server are being received and you want the router to step through each IP network when forwarding DHCP requests.

ip default-gateway Defines a default gateway (router); used on routers or communication servers that have IP routing turned off. The router or communication server acts just like a host on the network.

ip default-network Defines a default route that will be distributed to other routers.

Table F-6 IP Configuration Commands (Continued)

Page 16: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 17

Command Meaning

ip directed-broadcast Enables the translation of directed broadcasts to physical broadcasts. In Cisco IOS Release 12.0 and later, the no ip directed-broadcast command is on by default.

ip domain-lookup Turns on DNS lookups; disabled with the no ip domain-lookup command.

ip forward-protocol Defines the protocols that will be forwarded with the ip helper-address command.

ip hello-interval eigrp Defines the interval at which EIGRP hello packets are sent.

ip helper-address Defines an address to which the router will forward certain broadcasts (this is usually a server address) that are sent to this interface.

ip hold-time eigrp Defines the time that a router will consider an EIGRP neighbor up without receiving a hello (or some other packet).

ip host Defines a static hostname to IP address mapping.

ip igmp join-group Configures the router to join the specified multicast group; the router accepts multicast packets in addition to forwarding them.

ip igmp static-group Configures the router itself as a statically connected member of the multicast group. The router does not accept the group’s packets itself, but only forwards them.

ip multicast-routing Enables IP multicast on a router.

ip ospf area Enables OSPF directly on an interface.

ip ospf authentication Specifies the type of OSPF authentication to use on the interface.

ip ospf authentication-key Assigns a password to be used for OSPF authentication on an interface.

ip ospf cost Defines the outgoing OSPF cost of an interface.

ip ospf message-digest-key Specifies the key ID and key to be used for OSPF MD5 authentication on an interface.

ip ospf network Defines the OSPF network mode configuration (broadcast, non-broadcast, point-to-multipoint [non-broadcast], or point-to-point).

continues

Table F-6 IP Configuration Commands (Continued)

Page 17: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

18 Appendix F: Summary of BSCI Router Commands

Command Meaning

ip ospf priority Defines the OSPF priority on an interface (the default is 1); used to determine which router will be the designated router (DR) on a multiaccess network.

ip pim send-rp-announce Configured on a router that you want to be a rendezvous point (RP). This router sends an auto-RP message to the 224.0.1.39 address, announcing the router as a candidate RP for the groups in the range described by the access list specified in this command, only within a hop radius dictated by the scope value specified in this command.

ip pim send-rp-discovery Configures a router as an RP-mapping agent; it listens to the 224.0.1.39 address and sends a RP-to-group mapping message to the 224.0.1.40 address, only within a hop radius dictated by the scope value specified in this command. Other Protocol Independent Multicast (PIM) routers listen to the 224.0.1.40 address to automatically discover the RP.

ip pim sparse-dense-mode Enables the interface on the router to operate in sparse mode for sparse mode groups (those with known RPs) and in dense mode for other groups.

ip pim sparse-mode Enables PIM sparse mode operation on the selected interface.

ip pim spt-threshold Controls the switchover from the shared tree to source tree in PIM sparse mode.

ip policy route-map Defines a route map to use for policy routing on an interface.

ip prefix-list Defines a prefix list.

ip prefix-list description Defines a description for a prefix list.

ip prefix-list sequence-number Reenables the automatic generation of sequence numbers for a prefix list (automatic generation is the default); use the no form of this command to disable the automatic generation of sequence numbers.

ip rip send version Specifies the version of RIP packets sent, on a per interface basis.

ip rip receive version Specifies the version of RIP packets to accept, on a per interface basis.

ip route Defines a static route to an IP destination.

ip route-cache policy Enables fast switching of IP policy routing on an interface.

ip router isis Enables an interface to use IS-IS to distribute its IP routing information.

ip subnet-zero Allows use of subnets with all subnet bits equal to 0.

Table F-6 IP Configuration Commands (Continued)

Page 18: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 19

Command Meaning

ip summary-address eigrp Defines IP EIGRP route summarization on an interface.

ip summary-address rip Defines RIP route summarization on an interface.

ip unnumbered Enables IP processing on a serial interface without assigning an explicit address to the interface.

ipv6 address Assigns an IPv6 address to an interface and enables IPv6 processing on the interface.

ipv6 cef Enables Cisco Express Forwarding (CEF) for IPv6 (CEFv6).

ipv6 ospf area Enables OSPF for IPv6 on an interface.

ipv6 ospf cost Specifies the OSPF cost of sending an IPv6 packet on an interface.

ipv6 ospf priority Specifies the OSPF for IPv6 priority, used in DR election.

ipv6 route Defines an IPv6 static route.

ipv6 router ospf Enables an OSPF Version 3 (OSPFv3) process on a router.

ipv6 unicast-routing Enables IPv6 routing on a router.

is-type Defines which IS-IS level (level-1 | level-1-2 | level-2-only) at which a router will operate.

isis priority Changes the IS-IS router priority on the interface to influence the designated IS (DIS) election.

isis circuit-type Defines which level of IS-IS adjacency (level-1 | level-1-2 | level-2-only) will be established over an interface.

isis metric Defines the IS-IS metric to be used on an interface. The default is 10.

key Specifies the EIGRP key ID and enters configuration mode for that key.

key chain Enters configuration mode for an EIGRP key chain, used for authentication.

key string Specifies the EIGRP key string (password) for EIGRP authentication.

lease For DHCP, specifies the duration of the lease.

match community Defines routes to be matched in a route map as those with a BGP community attribute value as specified in a community list.

continues

Table F-6 IP Configuration Commands (Continued)

Page 19: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

20 Appendix F: Summary of BSCI Router Commands

Command Meaning

match interface Defines routes to be matched in a route map as those that have a next hop out of one of the interfaces specified.

match ip address Defines routes to be matched in a route map, using IP standard or extended access lists.

match ip next-hop Defines routes to be matched in a route map as those that have a next-hop router address permitted by one of the access lists specified, using IP standard or extended access lists.

match ip route-source Defines routes to be matched in a route map as those that have been advertised by routers and access servers that have an address permitted by one of the access lists specified, using IP standard or extended access lists.

match length Defines minimum and maximum packet length values to be matched in a route map.

match metric Defines routes to be matched in a route map as those routes that have the metric specified.

match route-type Defines routes to be matched in a route map as those of the specified type.

max-lsa Specifies the maximum number of received OSPF LSAs that the router keeps in its link-state database (LSDB).

maximum-paths Controls the maximum number of equally good routes that an IP routing protocol will keep in the routing table.

metric For IS-IS, defines the IS-IS metric to be used on all interfaces.

metric weights Allows tuning of the EIGRP metric calculations.

neighbor Statically defines OSPF neighbor relationships over a nonbroadcast multiaccess (NBMA) network in nonbroadcast mode.

neighbor distribute-list Distributes BGP neighbor information, as specified in an access list.

neighbor ebgp-multihop Allows the router to accept and attempt BGP connections to external peers residing on networks that are not directly connected.

Table F-6 IP Configuration Commands (Continued)

Page 20: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 21

Command Meaning

neighbor next-hop-self Forces all BGP updates for this neighbor to be advertised with the source IP address of the update as the next-hop address for each network it advertises.

neighbor password Enables MD5 authentication on the TCP connection between two BGP peers and specifies the password to be used.

neighbor peer-group Creates a BGP peer group; assigns neighbors as part of a peer group.

neighbor prefix-list Identifies a prefix list to be used to filter BGP routes from or to a peer router.

neighbor remote-as Identifies a peer router with which this router will establish a BGP session.

neighbor route-map Applies a route map to incoming or outgoing BGP routes.

neighbor route-reflector-client Defines the router as a BGP route reflector and identifies the specified neighbor as its route reflector client.

neighbor send-community Specifies that the BGP communities attribute should be sent to a BGP neighbor.

neighbor shutdown Disables (administratively shuts down) an existing BGP neighbor or neighbor peer group.

neighbor soft-reconfiguration inbound

Forces the router to store all received BGP updates without modification so that they can be used to do an inbound soft reconfiguration.

neighbor update-source loopback

Forces BGP sessions to use the address of the specified operational loopback interface as the source address for BGP connections to this neighbor.

neighbor weight Defines the BGP weight attribute to a neighbor connection.

net Assigns a network-entity title (NET) to the router to identify it for IS-IS.

netbios-name-server For DHCP, specifies the NetBIOS WINS server that is available to a Microsoft DHCP client.

netbios-node-type For DHCP, specifies the NetBIOS node type for a Microsoft DHCP client.

continues

Table F-6 IP Configuration Commands (Continued)

Page 21: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

22 Appendix F: Summary of BSCI Router Commands

Command Meaning

network For RIP, EIGRP, and OSPF, defines the networks on which the routing protocol will run. For EIGRP and OSPF a wildcard mask may be used to identify specific networks. Starts up the routing protocol on all interfaces that are in that network and allows the router to advertise that network.

For OSPF, this command also defines the area that the interface will be in.

For BGP, this command allows BGP to advertise a route if it is already in the routing table (use the neighbor command to start up BGP).

For BGP, this command may define the subnet mask of the route.

For DHCP, specifies the subnet/network number and mask of the DHCP address pool.

next-server For DHCP, specifies the next server in the boot process of a DHCP client.

option For DHCP, specifies DHCP server options.

passive-interface Prevents routing updates from this routing protocol from being generated on an interface. Use the default option to set all interfaces to passive, and then use the no passive-interface command to enable routing on individual interfaces.

redistribute Defines the protocol that will be redistributed into this routing protocol; the protocol can include static and connected routes.

redistribute maximum-prefix Defines the maximum number of prefixes that will be redistributed into OSPF or IS-IS.

router bgp Defines BGP as an IP routing protocol and enters configuration mode for that protocol.

router eigrp Defines EIGRP as an IP routing protocol and enters configuration mode for that protocol.

router-id Specifies the OSPF router ID to use for this OSPF process.

router isis Defines Integrated IS-IS as an IP routing protocol and enters configuration mode for that protocol.

router odr Configures on-demand routing (ODR), on the ODR hub router.

router ospf Defines OSPF as an IP routing protocol and enters configuration mode for that protocol.

Table F-6 IP Configuration Commands (Continued)

Page 22: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

IP Configuration Commands 23

Command Meaning

router rip Defines RIP as an IP routing protocol and enters configuration mode for that protocol.

send-lifetime For EIGRP MD5 authentication, specifies the time period during which this key can be used for sending packets.

service dhcp Enables the DHCP server and relay agent, if they have been disabled with the no service dhcp command.

set as-path Modifies an autonomous system path for BGP routes.

set automatic-tag Automatically computes the BGP tag value.

set community Sets the BGP communities attribute within a route map.

set default interface Defines the default interface to which packets that have no explicit route to the destination should be forwarded from a route map.

set interface Defines the interface to which packets should be forwarded from a route map.

set ip default next-hop Defines the default next-hop address to which packets that have no explicit route to the destination should be forwarded from a route map.

set ip next-hop Defines the next-hop address to which packets should be forwarded from a route map.

set ip precedence Sets the IP precedence in the IP packets from a route map.

set ip tos Sets the IP type of service (ToS) value in the IP packets from a route map.

set level Indicates at what level or type of area to import routes into (for IS-IS and OSPF routes).

set local-preference Specifies a BGP local preference value for the autonomous system path.

set metric Sets the metric value for a routing protocol. For BGP, the metric is the MED.

set metric-type Sets the metric type for the destination routing protocol.

set origin Specifies the BGP origin code.

set tag Specifies the tag value for the destination routing protocol.

continues

Table F-6 IP Configuration Commands (Continued)

Page 23: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

24 Appendix F: Summary of BSCI Router Commands

WAN Configuration Commands

Table F-7 contains some Cisco IOS configuration commands related to WAN interface configuration.

Command Meaning

set weight Specifies the BGP weight value.

summary-address For OSPF, defines route summarization of external routes on an OSPF ASBR. For IS-IS, defines IP route summarization and may specify the area type into which the routes will be summarized.

synchronization Enables BGP synchronization.

timers active-time Defines the EIGRP active-state time limit (it defaults to 3 minutes).

timers basic Specifies ODR timers.

timers throttle spf Enables the OSPF throttling feature so that the SPF calculations can be potentially delayed during network instability.

traffic-share Defines how traffic is distributed among multiple unequal cost EIGRP routes for the same destination network.

tunnel destination Specifies the destination IP address of a tunnel interface.

tunnel mode ipv6ip Enables a manual IPv6 tunnel on a tunnel interfaces with IPv6 as the passenger protocol, and IPv4 as both the encapsulation and transport protocol.

tunnel source Specifies the source IP address of a tunnel interface.

variance Defines the multiplier used for EIGRP unequal-cost load balancing.

version Defines the version of RIP packets to send and accept.

Table F-7 WAN Configuration Commands

Command Meaning

encapsulation Defines the data-link encapsulation for an interface (ppp, hdlc, x25 [dte is the default, can use dce], frame-relay, and so on).

frame-relay interface-dlci Defines the Frame Relay DLCI number on a subinterface.

frame-relay intf-type dce Defines an interface as a Frame Relay DCE device.

Table F-6 IP Configuration Commands (Continued)

Page 24: The commands in this appendix are organized in the ...ptgmedia.pearsoncmg.com/imprint_downloads/cisco/bookreg/2237xxf.pdfmaximum of 11 packet types can be selected for individual or

CLNS Configuration Commands 25

CLNS Configuration Commands

Table F-8 covers commands related to CLNS configuration.

Command Meaning

frame-relay inverse-arp Enables Frame Relay Inverse Address Resolution Protocol (Inverse ARP) on an interface. Use the no form of the command to turn off Inverse ARP on an interface.

frame-relay map clns Maps a next-hop CLNS address to a Frame Relay permanent virtual circuit (PVC).

frame-relay map ip Maps a next-hop IP address to a Frame Relay PVC.

frame-relay switching Enables Frame Relay switching on the router.

frame-relay route Defines a static entry in the Frame Relay switching table.

Table F-8 CLNS Configuration Commands

Command Meaning

clns routing Enables routing of CLNS packets

clns host Defines a static hostname to CLNS address mapping

clns router isis Enables an interface to use IS-IS to distribute its CLNS routing information

Table F-7 WAN Configuration Commands (Continued)