uninets mpls lab manual ??-vpn-.pdf · uninets mpls lab manual uninets mpls lab manual lab: ospf...

Download UniNets MPLS LAB MANUAL ??-VPN-.pdf · UniNets MPLS LAB MANUAL UniNets MPLS LAB MANUAL Lab: OSPF Routing

Post on 30-Jun-2018

226 views

Category:

Documents

6 download

Embed Size (px)

TRANSCRIPT

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    MPLS

    UNiNets

    Multiprotocol label

    Switching

    MPLS LAB MANUAL

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    CCNP TOPOLOGY

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    Lab: OSPF Routing VPN

    Topology:

    Task1: Perform the basic Configuration to provide the reachability as per diagram.

    SW1 Configuration

    Conf t

    Vlan 12

    Vlan 23

    Vlan 34

    Vlan 45

    interface Ethernet1/0

    switchport access vlan 12

    switchport mode access

    duplex auto

    interface Ethernet2/0

    switchport access vlan 12

    switchport mode access

    duplex auto

    interface Ethernet10/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    interface Ethernet11/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    interface Ethernet12/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    interface Ethernet13/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    interface Ethernet14/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    interface Ethernet15/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    SW2 Configuration

    Conf t

    Vlan 12

    Vlan 23

    Vlan 34

    Vlan 45

    interface Ethernet2/0

    switchport access vlan 23

    switchport mode access

    duplex auto

    !

    interface Ethernet3/0

    switchport access vlan 23

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    switchport mode access

    duplex auto

    !

    interface Ethernet4/0

    switchport access vlan 45

    switchport mode access

    duplex auto

    interface Ethernet7/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet8/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet9/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    interface Ethernet10/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet11/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet12/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    SW3 Configuration

    Conf t

    Vlan 12

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    Vlan 23

    Vlan 34

    Vlan 45

    interface Ethernet3/0

    switchport access vlan 34

    switchport mode access

    duplex auto

    !

    interface Ethernet4/0

    switchport access vlan 34

    switchport mode access

    duplex auto

    !

    interface Ethernet5/1

    switchport access vlan 45

    switchport mode access

    duplex auto

    interface Ethernet7/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet8/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet9/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    interface Ethernet13/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

    interface Ethernet14/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    !

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    interface Ethernet15/0

    switchport trunk encapsulation dot1q

    switchport mode trunk

    duplex auto

    R1 Configuration

    interface Loopback0

    ip address 1.1.1.1 255.255.255.0

    !

    interface Loopback1

    ip address 192.168.1.1 255.255.255.0

    !

    interface Ethernet0/0

    ip address 10.1.12.1 255.255.255.0

    no shut

    R2 Configuration

    interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    !

    interface Ethernet0/0

    ip address 10.1.12.2 255.255.255.0

    no shut

    !

    interface Ethernet0/1

    ip address 10.1.23.2 255.255.255.0

    no shut

    R3 Configuration

    interface Loopback0

    ip address 3.3.3.3 255.255.255.0

    !

    interface Ethernet0/0

    ip address 10.1.23.3 255.255.255.0

    no shut

    !

    interface Ethernet0/1

    ip address 10.1.34.3 255.255.255.0

    no shut

    !

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    R4 Configuration

    interface Loopback0

    ip address 4.4.4.4 255.255.255.255

    !

    interface Ethernet0/0

    ip address 10.1.34.4 255.255.255.0

    no shut

    !

    interface Ethernet0/1

    ip address 10.1.45.4 255.255.255.0

    no shut

    !

    R5 Configuration

    interface Loopback0

    ip address 5.5.5.5 255.255.255.0

    !

    interface Ethernet0/1

    ip address 10.1.45.5 255.255.255.0

    no shut

    !

    interface Loopback1

    ip address 192.168.5.1 255.255.255.0

    !

    Verification:

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    TASK 2: Configure OSPF area 0 on R2, R3, and R4 on the links connecting the routers to each other and their L0 interface only.

    R2 Configuration

    router ospf 1

    network 2.2.2.2 0.0.0.0 area 0

    network 10.1.23.2 0.0.0.0 area 0

    R3 Configuration

    router ospf 1

    network 3.3.3.3 0.0.0.0 area 0

    network 10.1.23.3 0.0.0.0 area 0

    network 10.1.34.3 0.0.0.0 area 0

    R4 Configuration

    router ospf 1

    network 4.4.4.4 0.0.0.0 area 0

    network 10.1.34.4 0.0.0.0 area 0

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    TASK3 Configure Label Distribution Protocol on Core Routers. Ensure that the LDP-ID is based

    on the IP address assigned to the Loopback O interface of these router .

    Configure Following label ranges on these routers

    R2: 200 299

    R3: 300 399

    R4: 400- 499

    On all Routers:

    mpls label protocol ldp

    mpls ldp router-id loopback0

    R2 Configuration

    int eth0/1

    mpls ip

    int eth0/1

    mpls ip

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    mpls label range 200 299

    R3 Configuration

    int eth0/0

    mpls ip

    int eth0/1

    mpls ip

    mpls label range 300 399

    R4 Configuration

    int eth0/0

    mpls ip

    mpls label range 400 499

    Once done Reload to take this Effect.

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    TASK4: Configure MP-BGP between R2 R4 as they are RE routers and in AS 65001.Dont allow

    BGP peers to share IPV4 routing information by default. BGP Peering relationship will be

    VPNV4.

    R2 Configuration

    router bgp 65001

    bgp log-neighbor-changes

    no bgp default ipv4-unicast

    neighbor 4.4.4.4 remote-as 65001

    neighbor 4.4.4.4 update-source Loopback0

    !

    address-family ipv4

    exit-address-family

    !

    address-family vpnv4

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    neighbor 4.4.4.4 activate

    neighbor 4.4.4.4 send-community both

    neighbor 4.4.4.4 next-hop-self

    exit-address-family

    !

    R4 Configuration

    router bgp 65001

    bgp log-neighbor-changes

    no bgp default ipv4-unicast

    neighbor 2.2.2.2 remote-as 65001

    neighbor 2.2.2.2 update-source Loopback0

    !

    address-family ipv4

    exit-address-family

    !

    address-family vpnv4

    neighbor 2.2.2.2 activate

    neighbor 2.2.2.2 send-community both

    neighbor 2.2.2.2 next-hop-self

    exit-address-family

    TASK5: Configure following VRF Instance on following routers:

    R2: VRF Name: UNI

    RD: 1:10

    RT: 1:100

    R4: VRF name NET

    RD: 1:20

    RT: 1:100

  • UniNets MPLS LAB MANUAL

    UniNets MPLS LAB MANUAL

    R2 Configuration:

    ip vrf UNI

    rd 1:10

    route-target export 1:100

    route-target import 1:100

    !

    interface Ethernet0/

Recommended

View more >